Aquí puedes obtener las últimas distribuciones de Ruby en tu sabor favorito. La versión estable actual es 1.8.5. Por favor asegúrate de leer la licencia de Ruby.

El código fuente de Ruby

Instalar desde los fuentes es una buena solución para cuando te sientes confiado con tu plataforma y puedas necesitar configuraciones específicas para tu entorno. También es una buena solución en el caso de que no existan paquetes ya armados para tu plataforma.

  • Ruby 1.8.6 (md5: 23d2494aa94e7ae1ecbbb8c5e1507683) Versión estable (recomendada)
  • Snaphot estable Este es el archivo .tar.gz de la última versión estable del CVS. Debería ser mejor que la última versión estable.
  • Snaphot nocturno Este es el archivo .tar.gz de la última versión del CVS. Puede tener errores sin corregir.

Ruby en Windows

Hay varias opciones para instalar Ruby en la plataforma Windows. La primer opción es simplemente instalar los binarios compilados. La segunda opción es utilizar el one-click installer. Si no estás seguro sobre cómo instalar Ruby, el one-click installer puede ser tu mejor opción. (Además de Ruby, el one-click installer incluye un montón de bibliotecas).

Ruby en Linux

Dependiendo de la distribución que utilices, hay varias maneras de instalar Ruby. La primer opción es simplemente bajar el código fuente y compilarlo a mano. Pero en algunas plataformas, hay gestores de paquetes que hacen la instalación de Ruby extremadamente sencilla.

Por ejemplo, en Debian o Ubuntu apt-get provee una fácil y elegante solución:

% sudo apt-get install ruby irb rdoc

En el caso de Ubuntu, para irb y rdoc necesitarás habilitar el repositorio universe.

Ruby en OS X

Hay una cantidad de opciones en la plataforma Macintosh OS X para instalar la última versión de Ruby. Locomotive es una buena opción si estás buscando algo que rápidamente te permita desarrollar con Rails. El uso de DarwinPorts o Fink puede ser mejor para las personas con más conocimientos técnicos.

En DarwinPorts, puedes instalar Ruby con…

% port install ruby

Fink tiene una interfaz gráfica (usando Fink Commander) para instalar Ruby.

También, como OS X está basado en Unix, descargar e instalar desde el código fuente es tan fácil y efectivo como las otras soluciones.

Para ver en más detalle la instalación de Ruby (y Rails), el excelente artículo de Dan Benjamin Building Ruby, Rails, LightTPD, and MySQL on Tiger te ayudará a lograrlo rápidamente.

Nota: tanto Ruby 1.8.6 como Rails deberían venir preinstalados con la siguiente versión de Mac OS X, Leopard (actualmente en beta). (Más información aquí). Con suerte, cuando Leopard salga las cosas “simplemente funcionarán” como vienen.