Wyłączenie repozytorium CVS

Usługi CVS (włączjąc CVSup i CVSweb) zostaną wyłączone na stałe poczynając od 16 Marca 2007. Repozytorium z kodem zostało przeniesione na SVN

Jeśli potrzebujesz dostępu przez CVS do rezpozytorium, pobierz je przez CVSup przed 16 Marca 2007.

Repozytorium CVS przeniesione na SVN

Kod źródłowy Rubiego został przeniesiony do repozytorium SVN http://svn.ruby-online.co.uk/repos/ruby/. Możesz pobrać źródła przy uzyciu polecenia svn lub przeglądać kod za pomocą ViewVC.

Serwer na którym stoi svn.ruby-online.co.uk został dostarczony przez Sun Microsystems . Korzystamy z systemu operacyjnego Solaris 10 na nowym serwerze, działa całkiem dobrze.

13.1.2007 Noworoczne spotkanie Railsowe na Chłodnej 25

Wraz z początkiem nowego roku zapraszamy na kolejne spotkanie Railsowe. Jak zawsze zapraszamy wszystkich zainteresowanych Ruby on Rails, e-biznesem i rozwojem nowych technologii.

Spotkanie odbędzie się 13 stycznia 2007 (sobota) o godzinie 12 w klubokawiarni Chłodna 25 ( http://chlodna25.blog.pl ). Mamy nadzieję, że spotkanie w sobotę umożliwi przybycie jeszcze większej ilości osób.

Planowany przebieg spotkania:

Bardzo możliwe, że pojawi się jeszcze jedna prezentacja – czekamy na potwierdzenie. Po prezentacjach tradycyjnie panel dyskusyjny.

Dziękujemy Chłodnej 25 za pomoc w realizacji kolejnego spotkania.

Więcej…

Ruby on Rails Bootcamp w Niemczech

Od 26 do 30 Marca 2007 w Kloster Eberbach (niedaleko Frankfurtu) w Niemczech odbywać się będzie Ruby on Rails Bootcamp zorganizowany przez Big Nerd Ranch Europe.

Więcej informacji na http://www.bignerdranch.com/news/2006-12-20.shtml

Luka w cgi.rb

W bibliotece CGI (cgi.rb) znajdującej się w dystrybucji Rubiego wykryto lukę w zabezpieczeniach pozwalającą na zainicjowanie ataku “odmowy dostępu” – ang. “denial of service”, w skrócie DoS. Problem powstaje podczas wysłania zapytania HTTP, które używa “multipart MIME encoding” oraz nieprawidłowego znaku do określenia granicy (“-” zamiast “--“). Po wywołaniu takiego zapytania, zużywa ono całą dostępną pamięć w efekcie doprowadzając do sytuacji DoS.

Na atak narażone są wszystkie wersje Rubiego do 1.8.5 włącznie. Luka ta została opublikowana jako CVE-2006-5467.

Więcej…

2006 Archiwa…