Vous pouvez obtenir sur cette page les dernières versions de Ruby. La version stable actuelle est la 1.8.6. N’oubliez pas de lire la licence Ruby.

Le code source

Installer Ruby à partir des sources C est une bonne solution pour ceux qui sont sufisamment à l’aise avec leur plateforme de développement, et qui souhaitent éventuellement une configuration spécifique de leur environnement. C’est également la solution à adopter par défaut lorsqu’aucun paquetage « tout compris » n’existe pour votre plateforme.

  • Ruby 1.8.6-p110 (md5: 5d9f903eae163cda2374ef8fdba5c0a5) Version stable (recommandée)
  • Stable Snaphot Archive de la dernière version stable du CVS. A priori plus à jour que la dernière version stable publique.
  • Nightly Snaphot archive de la dernière version du CVS. Éventuellement instable.

Pour plus d’information sur le depot Subversion de Ruby, voyez la page Ruby Core.

Ruby sur Microsoft Windows

Il existe plusieurs façons d’installer Ruby sur la plateforme Microsoft Windows. La première consiste à installer les sources binaires précompilés ; la seconde est d’utiliser l’installateur « One-Click. » Si vous ne savez pas quoi choisir, l’installateur est vraisemblablement le moyen le plus simple (il installe par ailleurs, en plus de Ruby, plusieurs bibliothèques additionelles très utiles).

Ruby sur GNU/Linux

Il existe plusieurs moyens d’installer Ruby en fonction de la distribution que vous utilisez. Trivialement, vous pouvez télécharger le code source et compiler manuellement le projet. Cependant, certaines plateformes intègrent un système de paquetage qui permet d’installer Ruby très facilement, sans compilation manuelle.

Par exemple, sur Debian ou Ubuntu, apt-get rend les choses très faciles :

% apt-get install ruby1.8 irb1.8 rdoc1.8

Voyez selon votre propre système de paquetage.

Ruby sur Mac OS X

Ruby 1.8.6 est intégré dans Mac OS X Leopard, ainsi que Ruby on Rails, Mongrel, Capistrano et d’autres gems populaires. En savoir plus.

Mac OS X Tiger contient la version 1.8.2 de Ruby, mais pour ceux qui ne seraient pas passée à Leopard, il existe plusieurs méthodes pour obtenir la dernière version. Locomotive est tout indiqué si vous comptez utuliser Rails. Vous pouvez également passer par MacPorts ou Fink pour réaliser une installation plus fine.

Avec MacPorts, vous pouvez installer Ruby avec la commande :

% port install ruby

Fink est distribué avec une interface graphique (« Fink Commander ») que vous pouvez utiliser pour installer Ruby.

Il est interessant de noter que le systeme Mac OS X est basé sur UNIX, et que par conséquent télécharger et installer à partir des sources est aussi facile et efficace que les autres solutions.

Pour un meilleur aperçu sur l’installation de Ruby (et Rails), l’excellent article Building Ruby, Rails, LightTPD, and MySQL on Tiger (en anglais) de Dan Benjamin peut vous intéresser.